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Chapter 1   Introduction

ezData is a cross-platform data processing program for general purpose. It is able to read
most of text-format data file, as well as binary data if you know the internal structure of
the binary. See Functionalities for what it can do.

ezData is built with wxWidgets (formal wxWindows), an Open-
Source Cross-Platform GUI Library. Currently the windows
version is quite usable, and Linux version is also avaible. 

All the documentation, news, and newest version of ezData can be
got at my website: http://www.chemiLab.net/. Also you are welcome to leave
suggestions and report bugs there.

For Microsoft Windows:

The downloadable version is a zipped executable file, just download and unzip to your
disk and run it. MS windows 98 or upper is required.

Linux/GTK

The downloadable version is a tar.gz executable file, just download and gunzip, un-tar it to
your disk, change the mode to executable, and run it.

To run the binary, an i386 machine, GTK 1.x+, and several other basic linux libraries are
needed. The following is the output of "ldd ezData":

libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x40024000)
libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x40143000)
libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 
(0x40174000)
libgthread-1.2.so.0 => /usr/lib/libgthread-1.2.so.0 
(0x40177000)
libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x4017a000)
libpthread.so.0 => /lib/libpthread.so.0 (0x4019b000)
libdl.so.2 => /lib/libdl.so.2 (0x401ec000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x401f0000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x401fe000)
libpng.so.3 => /usr/lib/libpng.so.3 (0x402c5000)
libjpeg.so.62 => /usr/lib/libjpeg.so.62 (0x402ef000)
libtiff.so.3 => /usr/lib/libtiff.so.3 (0x4030c000)
libexpat.so.0 => /usr/lib/libexpat.so.0 (0x4034d000)
libz.so.1 => /usr/lib/libz.so.1 (0x4036d000)
libm.so.6 => /lib/libm.so.6 (0x4037a000)
libstdc++.so.5 => /usr/lib/libstdc++.so.5 (0x4039d000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x4044e000)
libc.so.6 => /lib/libc.so.6 (0x40456000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)
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Many thanks to Ms. Hong Zhao (An analytical chemist in the Department of Chemistry,
University of Pittsburgh, US). She performed the main tests and gave me a lot of valuable
advice.

1.1   Functionalities:
Import and Export
• Read and open most text or binary data files directly. No need of tedious opertions

such as “data=>import=>text file=>wizard”.
• Easy to tranfer your data files to ezData readable format by using data format editor

and analyzer.
• Able to read multi-column text data, or open multiple data files.

View
• Very convenient view operations
• Very versatile view options
• Graph copy-paste, printing
• Graph export to wmf, jpeg, tiff, xpm, png file
• Peak result copy-paste to any text editor or Excel

Data Process
• Smooth/filter
• Move or zoom horizontally or vertically
• Crop, cut, merge
• Correct base line automatically or manually

Peak Process
• Automatic or manual parameters for peak searching
• Time-table parameters for peak searching
• Matching table for peak searching
• Manually adding/removing/modifying peak(s), continuous operating mode
• Peak split or combination
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Chapter 2   Data File Format and File Management

In this chapter, you will get the idea of how to open, close, and save data files; how to
define a new data format to open your data.

ezData can open both binary data and text data. But it is difficult to figure out the structure
of a binary file. So here, I only give the guide of how to define the format for the text data.

Currently, most data acquisition/process systems have the ability to export the data to a
text file. Some programs provide to save the data  as a text file directly.

2.1   Data Format
To open the data file, first you should define a suitable format, which enables ezData to
recognize the format of your raw data. To define a data format, click Data File Formats in
the File menu. The Data Format Manager will be popped up:

At the first time you use ezData, there is no any pre-defined format. Click New Text, The
Data Format Editor will be popped up:
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Here, you can easily define your own data format. In the followed several sections, I will
give examples to show how this works.

The brief descriptions are:
• File Extension: The extension name for the data file. Make sure there is a leading dot.

Like “.txt”.
• Short Description: A brief description in the dialog when openning the file. Like

“PeakSimple Text file”.
• Description: - For your own record only.
• X-Unit/X-Label: - The label and the unit for axis x. Like “Second” for unit and “Time”

for label.
• Y-Unit/Y-Label: - The label and the unit for axis y. Like “mV” for unit and “Signal”

for label.
• Note and Skip: - Note is a description for the data, it can be viewed, modified, or

printed out. The number of note and skip together is the leading lines in the file which
are not the data and should be read as note or just skipped.

• Axis X Step: The interval for axis x. It means the length on axis x between two
conjected data. For example, we know the sampling frequency is 20Hz, so the interval
should be “0.05” (1second/ 20times=0.05second/time).
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If a negitive value is given, the curve will be flipped horizontally.
Please do not give a “zero” for it.

• Axis X Start From: The first value for the X. It will be ignored if the X is read from the
file.

• Read 1st column to get the start point and additional step. To read the axis X (start
point and step/interval) from the 1st column in the file, of cause the file should have
the data for axis X.
Even if the axis X is read from the file, “axis X step” mentioned before is still useful.
For example, the axis X is recorded with “millisecond” in the file and you input
“second” as the unit, a value of “0.001” for step X would convert the final interval
read from the file from “millisecond” to “second”.

• Axis Y Step: To convert the recorded data unit to the unit you selected. For example,
the data unit in the file is “uV” and you prefer “mV” as the unit for axis Y, a value of
“0.001” will make such conversion.
If a negitive value is given, the curve will be flipped vertically.
Please do not give a “zero” for it.

• Is it possible your data has ‘Nan’, ‘Inf’, or ‘-Inf’: Some kinds of data files may have
such kinds of special values. It is safe to always select this option, but that will slower
the loading speed a little bit.

• Data Columns: Which column(s) you want to be loaded. The format is
“column1:name1,column2:name2,....”. The name is optional, but if you fill the name,
the “:” must be insert between the column idx and the name. For example, the data has
two columns for “200nm” and “240nm” data, the data coulmns may look like
“1:200nm,2:240nm”, or simply “1,2”

Don’t be afraid of filling the blank. The most important fields, which are highlighted by
cyan background, can be filled by “Analyzer”! After that, normally you do not need to
modify other fields before openning and seeing your data on the screen. Of cause, you
may need to change somethings, like x,y step, to show the correct axises’ values.
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Click Analyzer to pop-up the Format Analyzer:

• Load Sample File: It is the first thing to do after openning the analyzer. If the sample
file is loaded successfully, you will see the content of the sample file in the lower-
window. Only the first 100 lines in the file will be loaded, normally it is enough for
anlyzing.
After loading the file, when the insert-cursor travling in the lower-window by mouse
clicking or arrow key, the current line number will show up near to “OK” button.

• Analyze: The content of the sample file will be parsed by analyzer. If you see
somethings are filled in the upper grid window, congratulation! Analyzer finds the
structure of the file! To verify the correction of the result: The column with header of
“Axis X” means that column is considered as the data for axis X. The column with
header of “Y” is the data on axis Y.

• 1st row is header: This function is used in case the analyzer does not figure out that
the row should be the column header. Sometimes it happens in the data from the
spectrometer, in which the column header is the wave-length.

• Set/unset Axis X: This function is used in case you’d like to switch whether the first
column is the data for axis X.

• If the data in the grid match your data shown in the lower window, click “OK” button
to returen the format editor dialog. Some fields will be filled in automatically.

You may need to modify some other fields in order to let the difined format exactly match
your data. Please refer to the following samples for the description of the fields.
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2.1.1 Example: “*.asc” file from PeakSimple Model 202 Chromatography Data 
System (SRI Instruments)

Text is not the native file format, but you have the option to save the file as text with
“.asc” as extension:

<LAB NAME>=SRI Instruments
<CLIENT>=Valued Customer
<CLIENT ID>=N2024
<COLLECTION DATE>=
<HOLDING TIME>=
<METHOD>=SYRINGE ON-COLUMN
<LAB ID>=
<DESCRIPTION>=CHANNEL 4
<COLUMN>=15METER MXT-1
<CARRIER>=HELIUM AT 5 PSI
<TEMPERATURE>=
<EVENTS>=
<COMPONENTS>=
<SAMPLE>=RUN1
<OPERATOR>=
<QC BATCH>=
<CONDITIONS>=TYPE YOUR COMMENTS HERE
<DATE>= 2-11-2004
<TIME>=18:28: 1
<RATE>=20Hz
<SIZE>=29565
<SAMP WEIGHT>=1.000000
<STD WEIGHT>=1.000000
<CONTROL FILENAME>=DEFAULT.CON
39868,39868
40210,40210
40614,40614
41728,41728
44016,44016
53046,53046 
........

The finished fields and descriptions are:
• File Extension: “.asc”
• Short Description: “PeakSimple ascii data”
• X-Unit/X-Label: From the data file, we can see axis x is time (line21). So we can

choose “Sec.” as the unit and “Time” as the label.
• Y-Unit/Y-Label: We use “mV” as the unit and “Signal” as the label.
• Note and Skip: The leading 25 lines are not so useful. “0” for note and “25” for skip.
• Axis X Step: From line 21, we know the frequency of sampling is 20Hz, so the interval

should be “0.05”(1second/ 20times=0.05second/times).
• Axis X Start From: The data is from “0”.
• Read 1st column to get the start point and additional step. Very clearly there is no data

column for axis x, so we will not let ezData read axis x from the file.
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• Axis Y Step: The original data unit is uV, it will let the data be very large and we’d like
to use mV as the unit, so fill in “0.001”(0.001mV=1uV) for it.

• Is it possible your data has ‘Nan’, ‘Inf’, or ‘-Inf’: There is no these kinds of special
values in the data file.

• Data Columns: There are two Columns, but the two are identical. We fill “1” for it.

2.1.2 Example: “*.fwk” file from OOIChem (Ocean Optics, Inc.)

OOIChem save its file with “.fwk” as extension but it is really a text file. Open it with a
text editor, it will look like this (the number of the data columns depends on the setting of
your data collecting):

Channel : Master
=============================== 
Integration Period (ms) :25
Average : 1
Boxcar smoothing (pixels) :1
Mode : Absorbance
wavelengths : 2
Time(ms)
=====
0 -3.7392E-3 -4.5342E-4
1047 -3.7392E-3 -1.1075E-3
2078 -8.8273E-4 2.2742E-3
3125 -3.6297E-3 -1.3086E-3
4172 -2.3133E-3 -4.5342E-4
........

• File Extension: “.fwk”.
• Short Description: “OOIChem 2-curve data”.
• X-Unit/X-Label: Axis X is time (line8), we'd like to use “Sec.” as the unit and “Time”

as the label.
• Y-Unit/Y-Label: Axis Y is Absorbance (line6), no unit for it and use “Abs.” as the

label.
• Note and Skip: The first “7” lines is a description of the data, read them as the note.

The line 8 and 9 would be useless, so skip these “2” lines.
• Axis X Step: We already selected Second as the unit for the axis x, but the data use "ms

(millisecond)" (line8) as the unit. 1 ms = “0.001” Second.
• Axis X Start From: Here we will read it from the first column in the file, so it doesn't

matter what value it is.
• Read 1st column to get the start point and additional step. Check it. The first column

is the time information, we can get axis x for it. 
• Axis Y Step: We may choose a suitable data range, it is very similar as adjusting the

“Absorbance Range” or “Amplifier Gain” on the instrument panel. Here we fill “1”
for it.

• Is it possible your data has ‘Nan’, ‘Inf’, or ‘-Inf’: Check it. sometimes, OOIChem
records these special values in the data file.
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• Data Columns: Column 1 is the axis X, column 2 and 3 is the data. We collect two
serials of data at 400nm and 450nm, we fill the blank with “2:400nm,3:450nm” or just
“2,3”

2.1.3 Example: “*.txt” file from BioFocus 3000 CE System (Analytical Instru-
ments, Ltd.)

Text is not the native file format, but you have the option to export the file as the text, you
name the extension. Here, suppose you use “.txt” as extension (4-point collecting):

C:\CE3000\HONG\02004\FEB20001.BFF
02-20-2004  5:09 PM

Time:   0.0000    Scan Interval:0.0027778
   205     210     215     220  
 0.00063  0.00052  0.00044  0.00030
 0.00064  0.00053  0.00044  0.00030
 0.00063  0.00053  0.00043  0.00028
 0.00061  0.00052  0.00042  0.00027
 0.00058  0.00050  0.00041  0.00026
 0.00055  0.00048  0.00040  0.00025
 0.00052  0.00046  0.00039  0.00023
........

• File Extension: “.txt”.
• Short Description: “BioFocus 4-point data”
• X-Unit/X-Label: “Sec.” and “Time”.
• Y-Unit/Y-Label: “mV” and “Signal”.
• Note and Skip: Read first “4” lines as note and skip “0” line.
• Axis X Step: From line 4, we know the interval of sampling is 0.002778, the acutal unit

is minute, so x-step should be 0.002778min x 60sec/min = “0.16667”sec.
• Axis X Start From: From line 4, we know it is “0”.
• Read 1st column to get the start point and additional step. No.
• Axis Y Step: The original data unit is volt, it will let the data be very small and we’d

like to use mV as the unit, so fill in “1000” for it.
• Is it possible your data has ‘Nan’, ‘Inf’, or ‘-Inf’: No.
• Data Columns: From line5, we know the column names.

“1:205nm,2:210nm,3:215nm,4:220nm”.

2.2   File Open, Close, and Save
Most operations are the same as that of other programs you daily use. Here, only different
points are mentioned.

2.2.1 File Open
• Using mouse when holding “ctrl” or “alt” allows you selected multiple files.
• If you try to open different type of files in one file open dialog, the result will be

unknown.
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2.2.2 File Close
• The operation of closing is curve-based, not file based. After all curves in a file are

closed, the file will be closed automatically.
• Any modification of data, like move, zoom, crop, smooth, will not be saved

automatically.
• Any modification of peaks will be save automatically.

2.2.3 File Save
• Data file can be saved to the native binary data for ezData.
• All current curves will be saved into the file, including all the modifications of the

data, like smoothing, cropping.
• The peaks will be saved automatically.
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Chapter 3   View, Copy, Export, and Print

3.1   Setting the Options for the Graph and Peak List
A sample graph is here:

Once define the data file format, it is exciting to open the data and have a look in the
graphic view. I will follow the setting dialog box to explain the settings and the
effects.The major settings of view can be accessed by clicking Options in View menu; it
will pop-up Set Options for View dialog:

X-Lable/Unit

Y-Lable/Unit

X-Axis

Y-Axis

Left-Line

Right-Line

Top-Line

Bottom-LineY-Ruler@bottom-left

X-Ruler@top-left Legend@top-rightPeak-Marker

Peak-BaseLine
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The settings are divided into several groups. They are:

3.1.1 General Settings

The contents for general settings can be seen in the figure above.

Axis Transfer
• Transfer unit for axis X from second to minute, when possible

Whether ezData will try to use minute as the unit for axis X in some cases. To let it
take effect, two conditions must be reached:
-) This option must be checked
-) The unit of axis X must be sec. or second (case-insensitive) when defining the 

data format
Note: When it takes effect, all the values for axis x will be transfered except half-width
for the peak.

Offset Every Curves
• Axis X / Axis Y

This option enables to move the data curve horizontally or vertically. This function
may be used to give out a better look of multiple curves. 
If the value is positive, the curves move to right/up; Or else, move to left/down. The
current selected curve does not move, the position of the others depends on the related
order with the current selected curve.
Normally, it is a good practice to set a negative value for axis Y. So, the orders for
graph, curve list, and curve list editor will be the same.
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View Range
• Axis X / Axis Y Automatically

When this option selected, ezData will handle the view range automatically. In most
cases, you will be satisfied with this.

• Axis X / Axis Y From ...To...
Use these options in the case you like to specialize the veiw reange.
Note: The values of From...To... are for a single curve. If you open multiply curves,
the range will be extended automatically.

On Graph, Shows
• X/Y Label/Unit

When checked, ezData will show the corresponding label and unit on the graph.
• Axis X/Y

When checked, ezData will show the axis’s ticker and corresponding value.
• Top/Bottom/Left/Bottom Line

When checked, ezData will draw the line surrounding the graph.
• X/Y Ruler

Whether and where to display the ruler. The ruler is used to show the value-size ratio
of the graph. The following shows a ruler for axis X at bottom-left corner:
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3.1.2 Peak Mark/List Settings

Peak List Mode

Several different mode for peak list (on the main frame, click “peak list” tab at the
bottom-left corner, you will see the peak list). 

Obviously, “For current curve only” only show the peaks on current selected curve.

For other 4 modes, all peaks on all loaded curves will be listed, with the different
orientation and order. The peaks on a certain curve will be displayed with the same color
of that curve. Try to set the different mode to see which one is suitable.

Orientation of the marker
• Either horizontally or vertically draw the peak-marker

Do I need illustration here ?
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General Options for marking
• Mark all curves

When checked, all peaks will be shown on the graph. About how to mark, it depends
on other settings below

• Mark base-line
When checked, the base-line of the peak will be shown on the graph. Normally, we
turn it on to check if you get the correct results, and turn it off when printing or
copying

Marking/Listing/Accuracy

This group of settings controls what and how the peak will be marked on the graph and be
listed in the peak-list window:
• Mark ?

When checked, the corresponding element(s) will be used to mark the peak on the
graph. If multiple elements are selected, they will be seperatated by “:”

• List ?
When checked, the corresponding element(s) will be listed in the peak-list window.

• Accuracy
How many digits after the decimal point. The settings are for both peak marker on
graph and values in peak list.

3.1.3 Legend Settings

The legend gives a clear illustration of the relationship between colors and curves. Also, it
can be used to quickly switch currect selected curve by double clicking it.

Show Legend At

The position of the legend. The legend can be put at the corner or on the curve.

Show Legend As

If “None” is selected, no legend will be displayed.

Using curves’ names is clear. But if the names are too long, using alphabet or number may
be better. The corresponding curve list can be copied into clipboard (see “Copying Curve
List” on page 17), or optionally printed out.
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3.1.4 Fonts Settings

To set the color on the graph. The curve’s color also effect the color in peak list. The
foreground color is not in the setting, it will be generated from “Background” color (the
complemented color of the background).

3.1.5 Color Settings

To set the color on the graph. The curve’s color also effect the color in peak list. The
foreground color is not in the setting, it will be generated from “Background” color (the
complemented color of the background).
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3.2   Zoom in, zoom out, and measure
Click the Zoom Out either in View menu or on the toolbar button, the graph will
immediately zoom out to the size to fit all curves’ range, or the range you set.

Clicking the Zoom In in View menu or on the toolbar button, the cursor will be change to
a magnifier. Move the mouse to a certain point, press and hold the left button, drag to the
second point and release the mouse button, the selected range will fit into the whole graph
window. After zooming-in, the horizontal/vertical scrollbars can be used to scroll the
window.

The operation for measure is very similar as zoom-in. Instead zooming in the graph, a pop-
up dialog will display and give the x,y values of selected range.

3.3   Copying
Copying Graph (MS Windows only)

The copy function can be accessed by click Copy Graph in Edit menu. If you resize the the
graph after pasteing to the same size as it on the screen, the resolution of it will be 300dpi
(dot per inch). The tricks of copying are:
• The graph may look bigger, resize it.
• If you want the bigger font in the destination graph: 1st reduce the graph size by

resizing ezData, then copy-paste, finally resize the graph to a bigger one in your
application, like Microsoft Word. Also you may change the font size in view options,
but the former is much simple.

• If the pasted graph does not look like the one in the ezData, try to paste it into MS
Word and re-copy/paste from word into your problematic application, like MS
PowerPoint.

Copying Peak List

Copy Peak List in Edit menu will copy everything in peak-list window into system
clipboard. The content can be directly paste into any tab-sensitive spreadsheet, like MS
Excel.

Copying Curve List

Copy Curve List in Edit menu will copy a list of curves currently loaded into system
clipboard. Depends on the setting of the legend, the content is different:

Legend Shows as Curve List Content
not show curveName1    curveName2    ......
Curves’ Name curveName1    curveName2    ......
Upper Alphabet A:curveName1    B:curveName2    ......
Lower Alphabet a:curveName1    b:curveName2    ......
Number 1:curveName1    2:curveName2    ......
ezData User’s Guide (http://www.chemiLab.net/) 17



3.4   Exporting
By clicking Export Graph in Edit menu, you can keep a copy of the current graph window
on the disk. Currently, “wmf”(MS Windows only),  “jpg”, “png”, “tiff”, “pcx” are
supported. If the exported graph will be printed later as the same size on the screen, the
resolution of it will be 300dpi (dot per inch).

By clicking Export Data in Edit menu, you will be prompted to select a text file and file
type for exporting the data. Currently, the data can be exported to csv(comma seperated
version) or tab(tab seperated version) file. Only overlapped part of all opened curvers will
be exported. The file is exported with the following format (delimiter is either ‘comma’ or
‘tab’ depending on the file type you selected):

Axis X unit: ____   Axis X label: _____
Axis Y unit: ____   Axis Y label: _____
Note: ____ (if exist)
(a blank line)
Axis X(delimiter)curveName1(delimiter)curveName2(delimiter)...
x1(delimiter)y1.1(delimiter)y2.1(delimiter)...
x2(delimiter)y1.2(delimiter)y2.2(delimiter)...
........

3.5   Printing
Page setting and Style and Printing under File menu will decide the overall style of the
print out. The details of graph and peak-list are defined in Options in View menu.

The graph will be printed out just as the same as the one on the screen. 

The file name, the file note, the curves’ list, and the peak list all are optionally printed. The
alignments of them also can be set seperately.
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Chapter 4   Data Processing

4.1   Curve List
After loading the data, the curve(s) in the file will be in curve list. You may see all curves
on the screen, if the suitable view range is set. Some operations are for all curves, but
some are just effective for the current selected curve. To select current curve, click the
choice box at the top-right corner of ezData and pick up the one you want:

Another easier way to switch the current curve is: by double clicking the legend. You
should let the legend show up (see “Show Legend At” on page 15) to in order to double
click it.

To change the curves’ name or re-order the curves, click Curve List in Data menu to pop
up Curve List Editor

:

The box with green background will be moved up/down if you click Move Up/Move
Down button.

Note: Any change will be lost unless you save your data explicitly.
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4.2   Property
By clicking Property in Data menu, you can change the lables and the units for axis X/Y,
as well as the note.

Note: Any change will be lost unless you save your data explicitly.

4.3   Smoothing
Smoothing allows fliter your raw data, and improve the accuracy of the peak searching.
The parameters of smoothing in the Options under Data menu.
• Half-Width: Half width of the peak. It is not needed to input an accurate value, an

approximate one is all right.
• Automatically apply filter when loading the data: When checked, every data will be

smoothed automatically while loading.

Note: The result of smoothing will be lost unless you save your data explicitly.

4.4   Moving
The current selected curve can be moved horizontally or vertically.

After clicking the Horizontally/Vertically Move in Data menu, the cursor will be change
to a cross. Move the mouse to a certain point, press and hold the left button, drag to the
second point and release the mouse button, the selected curve will be moved, the distance
of moving is the distance of the mouse moving on X or on Y.

Note: The result of moving will be lost unless you save your data explicitly.

4.5   flipping
The current selected curve can be flipped horizontally or vertically.

After clicking the Horizontally/Vertically flip in Data menu, the current selected curve wil
be flipped according its center position.

Note: The result of moving will be lost unless you save your data explicitly.

4.6   Zooming
The current selected curve can be stretched horizontally or vertically.

After clicking the Horizontally/Vertically Zoom in Data menu, you will be asked to input
a multiplier. “1” will not change the data, a value between (exclude) “0” and “1” will
compress the data, and a value greater than “1” will enlarge the data.

Note: The result of zooming will be lost unless you save your data explicitly.

4.7   Cropping
Cropping is for all loaded curves. Cropping will keep the selected axis-X range and
discards un-selected range. It does not apply to axis-Y.
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After clicking the Crop Data in Data menu, the cursor will be changed to a cross. Move the
mouse to a certain point, press and hold the left button, drag to the second point and
release the mouse button, the selected range will be kept and the outside will be discarded.

 Note: The result of cropping will be lost unless you save your data explicitly.

4.8   Cutting
The current selected curve can be cut off a certain range horizontally. Cutting discards the
selected range, though cropping discards the un-selected range.

After clicking the Cut Data in Data menu, the cursor will be changed to a cross. Move the
mouse to a certain point, press and hold the left button, drag to the second point and
release the mouse button, the selected horizontal range will be discarded. The data
following this range will move forward.

Note: The result of cutting will be lost unless you save your data explicitly.

4.9   Merging
The current selected curve can be merged with another curve.

After clicking the Merge in Data menu, you will be asked to choose another curve
merging into the current one. After that, two curve will be merged together, the current
curve will be changed and another one will be closed.

Note: Two curves must overlap with each other in order to be merged.

Note: The result of merging will be lost unless you save your data explicitly.

4.10   Base Line Correction
The drift of the base line can be corrected either automatically or manually. Both are
accessed by clicking Base Line Correct in Data menu.

Note: If you don’t care about the drift of the base line, only the peak result is important,
there is no any necessary to perform the base-line correction.

4.10.1 Automatically Base Line Correction

If there is no peak on the curve, that means you have not perform peak searching yet, or no
has been found. Base Line Correction will go to automatic mode. But, you still have to
pick up a percentage to the shape of the original base line. The following shows a data
which is suitable for automatically correction and the effect of different percentage you
selected:
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4.10.2 Manually Base Line Correction

Sometimes the baseline is really strange like this:

We use manually peak adding function (See “Adding a Peak” on page 26) to add 3 peaks
(actually, they can not be called “peaks”, we just need the peaks’ base to be the data’s base
line):

The original data

after correction by apply “100%Great”

after correction by apply “50%Great”
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Then, apply base line correction. We finally get the curve like this (100% Great):
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Chapter 5   Peak Processing

5.1   Set the Suitable Marker for Peaks
There are many different combinations about how to mark peaks. To turn the base line on,
it is very easy to verify the result of the peak searching; To turn multiply content on (like
half-width, height), you can quickly make a comparison on the graph. More detail can be
found at “Peak Mark/List Settings” on page 14.

5.2   Automatical Peak Searching
In most cases, you can get ideal results from automatical peak searching.

To apply peak searching, click Search in Peaks menu. To set the parameters for peak
searching, click Options in Peaks menu.

5.2.1 General Settings

Parameter Source: Automatically

When selected, the minimal half-width/height/area will be got automatically, the settings
for these three will be useless and they are disabled or hidden.

Parameter Source: Manually

When selected, the minimal area is read from “Minimal Peak Area”; the minimal half-
width and height are read from the table on the right side. For any parameter whose value
is equal to or less than “0”, it will be got automatically. (Only the necessary field in the
right side will be displayed.)

Parameter Source: Time-Table

When selected, the minimal area is read from “Minimal Peak Area”, if it is “0”, the value
will be got automatically. A set of position, minimal half-width, and minimal height are
read from the table on the right side. Several things should be notified:
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• The value of position is effected by sec=>min, but halfWidth is not
• After clicking OK, the table will be re-ordered by the value of the position
• No automatic parameters in the table
• The line with smallest value of position will be set to the start point of the curve
• The half-width and height will change from the previous point to the next point

linearly
• If the length of the curve is greater than the last point in the table, the values at the last

point will be used for the values after that point

Note: the “Min. HalfWidth” also has effect on the peak base line, though the effect is not
very big. Sometimes, adjusting it to the suitable value may cause much more reasonable
result, like following:

Find peak from....to....

Search peaks only within this range. If the value for “from” is “0”, search from the
beginning; if the value for “to” is “0”, search to the end.

5.2.2 Time Table Parameters

(See “Parameter Source: Time-Table” on page 24)

5.2.3 Peak Matching

automatic parameters or
a small value for minimal half-width

the minimal half-width set to 10 (sec)
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Apply Matching

When checked, apply peak matching by using this group of settings. A matched peak
means the position of a peak falls into a certain range defined by position and tolerance in
the matching table.

Remove un-matched peak(s)

When checking, only matched peak(s) will be kept; all others will be discarded.

Matching Table

You can use Add/Delete button to maintain the matching table, one line for one peak.
• Name

The matched peak will be given this name. It can be blank.
• Position

Where to match the peak. It will take effect with “Tolerance” together, see below.
• Tolerance (%)

The error percentage of the position used to match the peak. 
For the first line in the figure, the matching range should be:
  4.00-4.00x10% -- 4.00+4.00x10% = 3.60min -- 4.40min
So, the peaks with position between 3.60-4.40 will be matched.

• Method
Sometimes, within a certain matching range, there are multiple peaks. “Method” will
decide which one among them will be matched. The available methods are “closest”,
“biggest”, “highest”. If “Not” is selected, this line will not take any effect.

5.3   Manually Peak Operations
Automatic peak searching may not meet your requirement. This section is the solution.

5.3.1 Adding a Peak

Once clicking “Add Peak” button on the toolbar or in Peaks menu, ezData will be in peak
adding mode, the button keeps been pressed and some toolbar buttons and menubar will
be disabled. With this mode, you can continuously add peak by mouse. To go to normal
operating mode, click “Add Peak” button again.

To add a peak, move the mouse to the position which should be the start point of a peak
you will add, press and hold the left button, drag to the end point of that peak and release
the mouse button, the peak will be added. Continuously adding till all the peaks you want
are there.

Note: Only the horizontal positions of the mouse are used.

Add

Remove

Modify

Add Negative
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5.3.2 Adding a Negative Peak

Once clicking “Add Negative Peak” button on the toolbar or in Peaks menu, ezData will
be in negative peak adding mode, the button keeps been pressed and some toolbar buttons
and menubar will be disabled. With this mode, you can continuously add negative peak by
mouse. To go to normal operating mode, click “Add Negative Peak” button again.

To add a negative peak, move the mouse to the position which should be the start point of
a peak you will add, press and hold the left button, drag to the end point of that peak and
release the mouse button, the negative peak will be added. Continuously adding till all the
peaks you want are there.

Note: Only the horizontal positions of the mouse are used.

5.3.3 Removing a Peak

Once clicking “Remove Peak” button on the toolbar or in Peaks menu, ezData will be in
peak removing mode, the button keeps been pressed and some toolbar buttons and
menubar will be disabled. With this mode, you can continuously remove peak by mouse.
To go to normal operating mode, click “Remove Peak” button again.

To remove a peak, move the mouse to the position which is between the start point and
end point of the peak, click left button, that peak will be removed. Continuously remove
till no more un-wanted peak is there.

Note: Only the horizontal positions of the mouse are used.

5.3.4 Removing Multiple Peaks

It is more convenient and quick to remove a bunch of peaks in the peak-list window. By
clicking the “Peak List” tab at the bottom-left corner, the window will switch to the
window that shows peak-list.

In peak-list window, you can select multiple peaks by mouse clicking with holding the
“Ctrl” key or “Shift” key; or simply pressing mouse button down and dragging it to select
a range. After selecting, clicking “Remove Peak” button on the toolbar will remove all
peaks falling in or partly falling in the selected range.

5.3.5 Modifying a Peak

Once clicking “Modify Peak” button on the toolbar or in Peaks menu, ezData will be in
peak modifying mode, the button keeps been pressed and some toolbar buttons and
menubar will be disabled. With this mode, you can continuously modify peak by mouse.
To go to normal operating mode, click “Modify Peak” button again.

To modify a peak’s start point, move the mouse to the position which is between the start
point and the point of the peak’s tip, press and hold the left button, drag the start point to
the position you want, then release the mouse button, the start point of that peak will be
modified. 

To modify a peak’s end point, move the mouse to the position which is between the end
point and the point of the peak’s tip, press and hold the left button, drag the end point to
the position you want, then release the mouse button, the end point of that peak will be
modified. 
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Continuously till all the peaks satisfy you.

Note: Only the horizontal positions of the mouse are used.

5.3.6 Peak Combination

This function can be accessed by clicking “Peak Combine” in Peaks menu. Only two
peaks next to each other can be combined.

Move the mouse to the position within the start point and end point of a peak, press and
hold the left button, drag to another point within the start point and the end point of
another peak, the selected two peaks will be combined together.

Note: Only the horizontal positions of the mouse are used.

5.3.7 Peak Splitting

This function can be accessed by clicking “Peak Split” in Peaks menu. 

Move the mouse to the position within the start point and end point of a peak, the
horizontal position should be the point where you want to split the peak, click the left
button, the selected peak will be split to two peaks.

Note: Only the horizontal positions of the mouse are used.

Split

Combine
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